Limit Extensi dengan Layer7 di Mikrotik

Paste code dibawah ini di Terminal Mikrotik

/ip firewall layer7-protocol
add comment=”” name=High regexp=”^.*get.+\.(exe|rar|iso|zip|dmg|7zip|0[0-9][1-9]|flv|mkv|avi|mp4|3gp|rmvb|mp3|img|dat|mov).*$”
add comment=”” name=Mid regexp=”^.*get.+\.(zip|rar|7z).*$”
add comment=”” name=End regexp=”^.*get.+\.(pdf|doc|docx|xlsx|xls|rtf|ppt|ppt).*$”
add comment=”” name=Video regexp=”http/(0\.9|1\.0|1\.1)[\x09-\x0d ][1-5][0-9][0-9][\x09-\x0d -~]*(content-type: video)”
add comment=”” name=Update-an regexp=”^.*get.+\.(bin|idx|cab|gz|avc|gem|mcs|klz|dat|kdc).*$”
add comment=”” name=youtube regexp=”o-o.preferred.pttelkom-|a.youtube.com|b.youtube.com|c.youtube.com|d.youtube.com|e.youtube.c om|f.youtube.com|g.youtube.com|h.youtube.com|i.youtube.com|j.youtube.com|l.youtube.com”

/ip firewall mangle
add action=mark-packet chain=forward comment=”High Eks” disabled=no
layer7-protocol=High new-packet-mark=High-Ext passthrough=no protocol=tcp
add action=mark-packet chain=forward comment=”Mid Eks” connection-bytes=
10485760-4294967295 disabled=no layer7-protocol=Mid new-packet-mark=
Mid-Ext passthrough=no protocol=tcp
add action=mark-packet chain=forward comment=”Low Eks” disabled=no
layer7-protocol=High new-packet-mark=End-Ext passthrough=no protocol=tcp
add action=mark-packet chain=forward comment=Video disabled=no
layer7-protocol=youtube new-packet-mark=Video passthrough=no protocol=tcp
add action=mark-packet chain=forward comment=Updatean disabled=no
layer7-protocol=Update-an new-packet-mark=Update-an passthrough=no
protocol=tcp

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0
max-limit=0 name=”Limit(Ekstensi|Streaming|Updatean)” parent=global-out
priority=3
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=64k
max-limit=192k name=High packet-mark=High-Ext parent=
“Limit(Ekstensi|Streaming|Updatean)” priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=256k
max-limit=512k name=Mid packet-mark=Mid-Ext parent=
“Limit(Ekstensi|Streaming|Updatean)” priority=6 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=512k
max-limit=1M name=End packet-mark=End-Ext parent=
“Limit(Ekstensi|Streaming|Updatean)” priority=4 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=64k
max-limit=128k name=Stream-Video packet-mark=Video parent=
“Limit(Ekstensi|Streaming|Updatean)” priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=128k
max-limit=256k name=Update-an packet-mark=Update-an parent=
“Limit(Ekstensi|Streaming|Updatean)” priority=5 queue=default

Sumber